Share jOOQ on Facebook
Share jOOQ on Twitter

All versions: 3.9 | 3.8 | 3.7 | 3.6 | 3.5 | 3.4 | 3.3 | Development versions: 3.10 | Unsupported versions: 3.2 | 3.1 | 3.0 | 2.6 | 2.5

A list of supported databases

Every RDMBS out there has its own little specialties. jOOQ considers those specialties as much as possible, while trying to standardise the behaviour in jOOQ. In order to increase the quality of jOOQ, some 70 unit tests are run for syntax and variable binding verification, as well as some 400 integration tests with an overall of around 4000 queries for any of these databases:

  • CUBRID 8.4
  • DB2 9.7
  • Derby 10.10
  • Firebird 2.5
  • H2 1.3
  • HANA
  • HSQLDB 2.2
  • Informix 12.10
  • Ingres 10.1
  • MariaDB 5.2
  • Microsoft Access 2013
  • MySQL 5.5
  • Oracle 10g
  • PostgreSQL 9.0
  • SQLite with Xerial JDBC driver
  • SQL Azure
  • SQL Server 2008 R8
  • Sybase Adaptive Server Enterprise 15.5
  • Sybase SQL Anywhere 12

For an up-to-date list of currently supported RDBMS, please refer to http://www.jooq.org/legal/licensing/#databases.

The jOOQ Logo