All versions: 3.13 | 3.12 | 3.11 | 3.10 | 3.9 | 3.8 | Development versions: 3.14 | Unsupported versions: 3.7 | 3.6 | 3.5 | 3.4 | 3.3 | 2.6

Dependencies

Available in ✅ Open Source Edition   ✅ Express Edition   ✅ Professional Edition   ✅ Enterprise Edition

Dependencies are a big hassle in modern software. Many libraries depend on other, non-JDK library parts that come in different, incompatible versions, potentially causing trouble in your runtime environment. jOOQ has no external dependencies on any third-party libraries.

However, the above rule has some exceptions:

The jOOQ Logo